Queues Failing: Users / Leads / Calls Stuck in Queue

Incident Report for NexusVC

Resolved

This incident has been resolved. All queues are operational.
Posted Jul 17, 2023 - 12:40 EDT

Monitoring

A fix has been implemented and we are continuing to monitor the server(s) performance.
Posted Jul 15, 2023 - 21:22 EDT

Identified

We have identified part of the issues causing these queues to become unresponsive. We have begun to migrate components of the application into segmented server instances for individual auto-scaling based on demand.
Posted Jul 13, 2023 - 05:30 EDT

Update

We are continuing to investigate the queue's failing. A partial fix has been applied to the Websocket component that should help reduce these issues. We will update this incident has we learn more about the failing queues.
Posted Jul 11, 2023 - 22:42 EDT

Investigating

We are currently investigating an issue related to Users, Leads, Calls being stuck in a queue(s). This is an ongoing issue as we investigate further we will continue to update you on the status as we learn more.
Posted Jul 11, 2023 - 14:34 EDT
This incident affected: Ally (Ally) and Queue (CalculateStats, UpdateAgentCallHistory, UpdateUserStats, UserAvailable).